iPhone App Directory
RPG Maker VX
 
Gallery Members Search Calendar Help


Welcome Guest ( Log In | Register )

Collapse

>Announcement

Keep an eye out for the upcoming 3rd Quarter Contest!
4 Pages V  < 1 2 3 4 >  
Reply to this topicStart new topic
> KGC_LargeParty Compatibility for Tankentai SBS with ATB, V4.3 ~ Swap Actors During Battle! ~ new feature update
sephidevil92
post Aug 2 2010, 12:26 PM
Post #41



Group Icon


Type: Undisclosed




Hey sparkyg13

i have two questions:

can you change the "Swap" Command above Attack?
like this: Attached File  Example1.png ( 496.77K ) Number of downloads: 56


and can you remove the ATB´s
when select a character?
Attached File  Example2.png ( 482.37K ) Number of downloads: 47


This post has been edited by sephidevil92: Aug 2 2010, 12:26 PM
Go to the top of the page
 
+Quote Post
   
sparkyg13
post Aug 2 2010, 01:11 PM
Post #42


x^2
Group Icon


Type: Coder
Alignment: Unaligned




QUOTE (sephidevil92 @ Aug 2 2010, 08:26 AM) *
Hey sparkyg13

i have two questions:

can you change the "Swap" Command above Attack?
like this: Attached File  Example1.png ( 496.77K ) Number of downloads: 56


and can you remove the ATB´s
when select a character?
Attached File  Example2.png ( 482.37K ) Number of downloads: 47


done! just download and install the latest version and those problems will be fixed.


--------------------
/yawn
Go to the top of the page
 
+Quote Post
   
sephidevil92
post Aug 2 2010, 01:34 PM
Post #43



Group Icon


Type: Undisclosed




Thanks sparkyg13

this is really good^^
and very helpful
smile.gif THANKS!^^
Go to the top of the page
 
+Quote Post
   
edumazieri
post Sep 20 2010, 09:36 PM
Post #44



Group Icon


Type: Designer
Alignment: Unaligned




There is a problem when using the WAIT atb mode.

well... after the swap, the atb mode becomes active... so, it doesn't stop when the next ally gets to select commands, or anytime after that.

how do i fix that?


--------------------
#=========================================== A Dust Tale


Go to the top of the page
 
+Quote Post
   
sparkyg13
post Sep 20 2010, 10:10 PM
Post #45


x^2
Group Icon


Type: Coder
Alignment: Unaligned




QUOTE (edumazieri @ Sep 20 2010, 05:36 PM) *
There is a problem when using the WAIT atb mode.

well... after the swap, the atb mode becomes active... so, it doesn't stop when the next ally gets to select commands, or anytime after that.

how do i fix that?


well again that was something I forgot to include.. (stupid me tongue.gif)
anyways, I think I fixed it, just download the latest version..


--------------------
/yawn
Go to the top of the page
 
+Quote Post
   
edumazieri
post Sep 21 2010, 01:07 AM
Post #46



Group Icon


Type: Designer
Alignment: Unaligned




wow ur fast lol

it's perfect now ;p thanks a lot!


--------------------
#=========================================== A Dust Tale


Go to the top of the page
 
+Quote Post
   
edumazieri
post Sep 22 2010, 09:36 PM
Post #47



Group Icon


Type: Designer
Alignment: Unaligned




i've been having a problem... again.


i use swap type 1, so an actor picks the exchange command, it shows the window, then if i just select some guy to switch its ok, but if i cancel that window and go back to the actor commands and pick an action like attack or guard, it does nothing , it doesnt crash but, it just hangs. the atbs stopped and all.

ive been editting the layouts of my scenes, and i tought i broken it, then i came here and put the script back in, and same error.
i cant seem to remember if thta was happening yesterday ;\ maybe i didnt try it, idk


help?

This post has been edited by edumazieri: Sep 22 2010, 10:47 PM


--------------------
#=========================================== A Dust Tale


Go to the top of the page
 
+Quote Post
   
sparkyg13
post Sep 22 2010, 09:52 PM
Post #48


x^2
Group Icon


Type: Coder
Alignment: Unaligned




@edumazieri :

okay, I was able to fix your first problem, but you say you get 7 error messages? Could you possibly post a picture of these errors, I'm not exactly sure what your talking about.


--------------------
/yawn
Go to the top of the page
 
+Quote Post
   
edumazieri
post Sep 22 2010, 10:54 PM
Post #49



Group Icon


Type: Designer
Alignment: Unaligned




u were?, is it fixed on the first page download?

well, nvm that, i fixed it again... idk it happens on the terminate part, where it disposes every window. aparently they are already disposed then it says "failure to dispose nil" for each of those 7 @xxxxx.dispose
probably cuz of me messing around, or some other script i have, mnaybe, idk, anyway i commented out the commands and it worked (surprisingly putting a if @xxxx != nil didnt work )


EDIT: can u just give me the code of what u changed to fix that error? cuz i dont wanna repaste it and have to config it all again (i added backgrounds and etc...)

This post has been edited by edumazieri: Sep 22 2010, 10:55 PM


--------------------
#=========================================== A Dust Tale


Go to the top of the page
 
+Quote Post
   
sparkyg13
post Sep 22 2010, 11:04 PM
Post #50


x^2
Group Icon


Type: Coder
Alignment: Unaligned




no, it's not up on the first page yet, I wanted to know about your second problem first, before I did that.
I cannot seem to recreate your second problem. I'm not sure, but I think it has to do with a conflict with some other script you might have, which is weird because I have it aliased. eh, i don't know....

but anyways I'll go ahead and put in the updated version right now, just give me a minute or two and it should be up..

ok, it's up

This post has been edited by sparkyg13: Sep 22 2010, 11:20 PM


--------------------
/yawn
Go to the top of the page
 
+Quote Post
   
edumazieri
post Sep 22 2010, 11:17 PM
Post #51



Group Icon


Type: Designer
Alignment: Unaligned




QUOTE (sparkyg13 @ Sep 23 2010, 12:04 AM) *
no, it's not up on the first page yet, I wanted to know about your second problem first, before I did that.
I cannot seem to recreate your second problem. I'm not sure, but I think it has to do with a conflict with some other script you might have, which is weird because I have it aliased. eh, i don't know....

but anyways I'll go ahead and put in the updated version right now, just give me a minute or two and it should be up..



about just giving me a little code thing instead of the whole script... possible?
and tell me where was the error cuz it drove me crazy lol


--------------------
#=========================================== A Dust Tale


Go to the top of the page
 
+Quote Post
   
sparkyg13
post Sep 22 2010, 11:28 PM
Post #52


x^2
Group Icon


Type: Coder
Alignment: Unaligned




well it would be possible to give you the code, but I have to upload it anyway for everyone else too, but if just want the code to fix the problem, here it is:

Spoiler:

under 'def party_selection_off' (somewhere around line 800) you should see this:

CODE

elsif @from_party_window and Sparkys::Redefpr::PARTY_SWAP_TYPE == 1
$in_action = true
......

change the $in_action to $in_command and that will fix your first problem


--------------------
/yawn
Go to the top of the page
 
+Quote Post
   
edumazieri
post Sep 23 2010, 12:26 AM
Post #53



Group Icon


Type: Designer
Alignment: Unaligned




QUOTE (sparkyg13 @ Sep 23 2010, 12:28 AM) *
well it would be possible to give you the code, but I have to upload it anyway for everyone else too, but if just want the code to fix the problem, here it is:

Spoiler:

under 'def party_selection_off' (somewhere around line 800) you should see this:

CODE

elsif @from_party_window and Sparkys::Redefpr::PARTY_SWAP_TYPE == 1
$in_action = true
......

change the $in_action to $in_command and that will fix your first problem



i knew it was in party_selection_off and imagined some variable that defined the command ending or not was screwing up lol
i was close \o


--------------------
#=========================================== A Dust Tale


Go to the top of the page
 
+Quote Post
   
cyberjago
post Nov 29 2010, 06:10 AM
Post #54



Group Icon


Type: Undisclosed




im still newbie tough, can i change the setting so we can only swap party when not in battle?(sorry for bad english)
Go to the top of the page
 
+Quote Post
   
sparkyg13
post Nov 29 2010, 06:37 AM
Post #55


x^2
Group Icon


Type: Coder
Alignment: Unaligned




you can do this with an event, assuming you have the KGC_LargeParty script, since it is required for this script to work..

create the event and add a new event command, on the page of event commands go to page 3, under the Advanced section click Script when the new window pops up type this:

then click Ok
if you want the event to do this automatically you can set the event trigger to parallel process, but if you are going to do that be sure to put another event command that turns Self Switch 'A' on. then make another event page and set that page's condition to Self Switch 'A'. and if you want to allow swapping again in battle then do the same thing except instead of 'false' for the script put 'true'.


wait, no.. that wont work... apparently, I'm still an idiot tongue.gif.. I'll have this fixed in just a moment, since I'm about to release the new version anyway..

This post has been edited by sparkyg13: Nov 29 2010, 06:41 AM


--------------------
/yawn
Go to the top of the page
 
+Quote Post
   
Xaver_Entropia
post Nov 30 2010, 11:06 AM
Post #56



Group Icon


Type: Writer
Alignment: Chaotic Good




I think i found a problem. Im using mode 1, btw.

Sometimes when I use the attack command and cancel it in the enemy selection, and then swap the character, the character will sometimes perform the attack and then swap, or even, swap and then return, attack and swap again.
It happens in both this new version and the previous 1.

Also, sometimes when using the WAIT mode of the ATB, when swaping characters, the bars wont stop.

I think it happens when the swapped character enters with the atb bar full.

Anyway, great script. thank you.


--------------------
"Yes, the twelve legendary weapons. They are weapons. They are legendary. There are even twelve of them." FFV

Go to the top of the page
 
+Quote Post
   
sparkyg13
post Dec 1 2010, 08:06 AM
Post #57


x^2
Group Icon


Type: Coder
Alignment: Unaligned




thanks for reporting this issue, but I have already have it taken care of.. the newest version is just taking me a little longer than I expected to finish, but I'll have it ready as soon as I can... at the most, it will probably be by the end of the week.


--------------------
/yawn
Go to the top of the page
 
+Quote Post
   
Xaver_Entropia
post Dec 2 2010, 10:07 AM
Post #58



Group Icon


Type: Writer
Alignment: Chaotic Good




It works great now, good job!


--------------------
"Yes, the twelve legendary weapons. They are weapons. They are legendary. There are even twelve of them." FFV

Go to the top of the page
 
+Quote Post
   
chowdahrogansora...
post Jul 24 2011, 08:14 PM
Post #59



Group Icon


Type: Undisclosed




Hello, I'm new here, and i've got a question:
In my planned game, there are certain times when the party is temporarily grown to 6 members instead of 4, then letting the player organize the party immediatly afterwards before going into battle. When doing that, i used a command that depended on something from the KGC Large Party Script
CODE
set_max_battle_member_count(6)

then setting it back to 4 when the battle was over.

When i tested this process, it only had the first four members shown, and only they could act, even with this patch. Looking over the Patch's script, I saw:
CODE
# MAX_MEMBERS :: Specify the maximum number of members in battle
# This overrides both the 'MAX_BATTLE_MEMBERS' in KGC_LargeParty and
# 'MAX_MEMBER' in the SBS General Settings
# default = 4
MAX_MEMBERS = 4

Since MAX_MEMBERS overrides everything, can you script me something that'll allow me to change party size like I described? Much appreciated!

oh, and one more problem:
The "Party" command doesn't show when I bring up the Party Commands (like, it's still just "Fight/Escape")
I looked everywhere in the scripts and this topic, but no luck. Oh, and i'm just using the Tankentai + ATB, not the Spin command thing, if that makes any difference.

This post has been edited by chowdahrogansorah: Jul 24 2011, 08:21 PM
Go to the top of the page
 
+Quote Post
   
sparkyg13
post Jul 24 2011, 10:18 PM
Post #60


x^2
Group Icon


Type: Coder
Alignment: Unaligned




QUOTE (chowdahrogansorah @ Jul 24 2011, 04:14 PM) *
Hello, I'm new here, and i've got a question:
In my planned game, there are certain times when the party is temporarily grown to 6 members instead of 4, then letting the player organize the party immediatly afterwards before going into battle. When doing that, i used a command that depended on something from the KGC Large Party Script
CODE
set_max_battle_member_count(6)

then setting it back to 4 when the battle was over.

When i tested this process, it only had the first four members shown, and only they could act, even with this patch. Looking over the Patch's script, I saw:
CODE
# MAX_MEMBERS :: Specify the maximum number of members in battle
# This overrides both the 'MAX_BATTLE_MEMBERS' in KGC_LargeParty and
# 'MAX_MEMBER' in the SBS General Settings
# default = 4
MAX_MEMBERS = 4

Since MAX_MEMBERS overrides everything, can you script me something that'll allow me to change party size like I described? Much appreciated!

oh, and one more problem:
The "Party" command doesn't show when I bring up the Party Commands (like, it's still just "Fight/Escape")
I looked everywhere in the scripts and this topic, but no luck. Oh, and i'm just using the Tankentai + ATB, not the Spin command thing, if that makes any difference.


as for your first issue, i'll be updating the script later on tonight or tomorrow that will fix your issue smile.gif

and for your second issue, in the customization options you most likely have PARTY_SWAP_TYPE equal to 1, just change that to a 0, so it looks like this:
CODE
PARTY_SWAP_TYPE = 0



--------------------
/yawn
Go to the top of the page
 
+Quote Post
   

4 Pages V  < 1 2 3 4 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 

Lo-Fi Version Time is now: 2nd October 2014 - 11:35 AM

RPGMakerVX.net is an Privacy Policy, Legal.